Visa Settlement Reports

Incident Report for TabaPay

Resolved

Date: 28 Feb 2026
Description:
All missing Visa Settlement Reports were received from Visa…
Posted Feb 28, 2026 - 17:55 UTC

Monitoring

As of 02/28 7am PST, Visa latest status is:

We apologize for the delay. Unfortunately, there is not an estimated time frame at the moment.


Your patience has been greatly appreciated.
Posted Feb 28, 2026 - 15:01 UTC

Identified

Date: 28 Feb 2026
Description:
Visa Settlement Reports are late coming from Visa:
Your patience has been greatly appreciated
Posted Feb 28, 2026 - 14:37 UTC
This incident affected: TabaPay System Status.