MasterCard SMS

Incident Report for TabaPay

Resolved

Reported End Time: 28 May 2026 10:05 GMT
Description:

Mastercard Reference Number: INC000000574980

The incident has been resolved by MasterCard
Posted May 28, 2026 - 10:18 UTC

Investigating

Reported Start Time: 28 May 2026 08:08 GMT
Description:
Some transactions to MasterCard are timing out.
Posted May 28, 2026 - 09:38 UTC
This incident affected: TabaPay System Status.