MasterCard Settlement Reports

Incident Report for TabaPay

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 00:56 UTC

Identified

TabaPay has been notified by Mastercard that a reporting maintenance event is taking place today (04/17/2026) that could delay receiving MasterCard Settlement Reports. Clients will be notified if there will be further delays…
Posted Apr 17, 2026 - 15:05 UTC
This incident affected: TabaPay System Status.