Visa Dual Message

Incident Report for TabaPay

Resolved

Reported End Time: 02 Jun 2026 12:39 GMT
Description:

Visa is still investigation but everything is back to normal…

Visa Reference Number: INC25848052
Posted Jun 02, 2026 - 15:49 UTC

Investigating

Reported Start Time: 02 Jun 2026 12:23 GMT

Description:
Some transactions to Visa Dual Message were timing out.

We redirected traffic to our secondary site.
Posted Jun 02, 2026 - 12:46 UTC
This incident affected: TabaPay System Status.