Report Delivery Delay

Incident Report for TabaPay

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 18:30 UTC

Identified

A temporary service interruption affecting a third-party delivery provider has been resolved. As a result of the earlier interruption, scheduled report delivery will be delayed by approximately 60 minutes.

No action is required. We apologize for the delay and appreciate your patience.
Posted Aug 21, 2026 - 16:35 UTC
This incident affected: SLA.