Bank Statement Reporting Delay

Incident Report for TabaPay

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 20:35 UTC

Identified

Reported Date 08/20/2026
Description:
We are currently experiencing a delay in receiving Subledger Transaction Activity from one of our Sponsor Banks. As a result, TabaPay’s bank statement report generation is delayed.

Clients who receive TabaPay bank statement reports may experience a delay in receiving today’s statement(s).

We are actively monitoring the issue and will provide an update once report generation has resumed.

We apologize for the inconvenience and appreciate your patience.
Posted Aug 20, 2026 - 18:04 UTC
This incident affected: TabaPay System Status.