Visa Settlement Reports

Incident Report for TabaPay

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 00:30 UTC

Identified

Date: 05 June 2026
Description:
Visa Settlement Reports are delayed from Visa, impacting report availability this morning. We will provide an update as soon as the reports are received.
Your patience has been greatly appreciated
Posted Jun 05, 2026 - 17:09 UTC
This incident affected: TabaPay System Status.